Qualcast Classic 35s running problems

Cleaning, fixing, using, repairing, best and worst of your mechanical aids in the garden...

Moderators: Chantal, Tigger, KG Steve, peter

ramsrc
KG Regular
Posts: 1
Joined: Sat Apr 26, 2014 2:06 pm

Qualcast Classic 35s running problems

Postby ramsrc » Fri May 16, 2014 3:42 pm

First of all, as I am new here - hello to everyone. Hopefully someone knowledgeble can answer my question.

I have a Qualcast Classic 35s - which refuses to run properly. The symptoms are as follows, it will start and run nicely on tick-over, but as soon as I try to increase the revs the engine will either start to "hunt" or cut out all together.

My theory (from past experience) is that all is fine while idling, but when the throttle is opened, the main jet kicks in, and the mixture leans out - the governor then reduces the engine back to tickover, and the cycle starts again.

Normally, I would tweak the main jet mixture at this point - but the carb has a fixed main jet :x . I have drained and stripped the float bowl down, and I have the bowl nut in front of me, but I can't for the life of me find a hole in it anywhere!

I am struggling really hard to find any information about this carb (It has Dellorto FHC20 stamped on it) does anyone have any information that might help me further?
0 x
StephenH
KG Regular
Posts: 1
Joined: Wed Sep 21, 2016 8:08 am

Re: Qualcast Classic 35s running problems

Postby StephenH » Wed Sep 21, 2016 8:37 am

Hey?? you seems inactive at this forum? any specific reason for that? by the way i agree with your theory and i must say that you are a genius, i wish we could make this topic and forum active and interesting.
0 x
User avatar
Westi
KG Regular
Posts: 3670
Joined: Thu Oct 30, 2008 4:46 pm
Location: Christchurch, Dorset
x 337

Re: Qualcast Classic 35s running problems

Postby Westi » Wed Sep 21, 2016 7:22 pm

I'm surprised to see an unanswered post on Tools & Machinery even from 2 years ago! We do indeed have some geniuses on here who usually have the answer or link to fix anything! Welcome StephenH! Good observation, obviously been reading the posts and noted that.

Yep, it would be great to make the forum more active, every topic. I hope you'll stay and contribute.

Best Wishes, Westi
0 x
Westi
Richard
KG Regular
Posts: 42
Joined: Mon May 08, 2006 8:37 pm
Location: Lancaster
x 4

Re: Qualcast Classic 35s running problems

Postby Richard » Thu Sep 29, 2016 11:27 am

I don't know how I missed this in 2014 but recon I had answered it in another post anyway. However at over 1000 viewings, some owners must still be looking for answers. If the machine has been running happily and then starts to "only run on choke," this indicates the carb has got some dirt in a jet. Removing the carb and cleaning it is the answer. If the machine doesn't run properly after Winter, the advice given in my other post is all I can give:-
This carb is notorious for the only running on choke after the Winter lay up. Nothing you do will cure it except run on half choke until it clears its' self. Once it does clear, it will be OK until the next long lay up. A conversion kit to a variable main jet was available but no one seems to know who made it. Qualcast later changed to a different carb but by then the reputation of the A114 engine was ruined.
1 x

Return to “Tools and Machinery”

Who is online

Users browsing this forum: No registered users and 4 guests